Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
.net 6.0
#1
think this could be possible?
probably fial because of old binaries but thought i ask
webgrab is comming out with a new stand alone version that doesnt require mono but needs the above.
download links..
Download .NET 6.0 (Linux, macOS, and Windows) (microsoft.com)
Reply
#2
webgrab creator told me that .net 6.0 was needed which i installed on windows to test.
running the webgrab exe its looking for .net 5.0 though.

C:\Users\mike>"C:\Program Files (x86)\WebGrab+Plus\bin\WebGrab+Plus.exe" C:\Users\mike\AppData\Local\WebGrab+Plus
It was not possible to find any compatible framework version
The framework 'Microsoft.NETCore.App', version '5.0.0' (x64) was not found.
- The following frameworks were found:
6.0.1 at [C:\Program Files\dotnet\shared\Microsoft.NETCore.App]

You can resolve the problem by installing the specified framework and/or SDK.

The specified framework can be found at:
- https://aka.ms/dotnet-core-applaunch?fra...=win10-x64

once i installed that it worked on windows.
now on to linux.
i downloaded the linux binaries for my nas(x64 in my case)
extracted them upload it to my nas.
trying to run it its looking for GBLIC 2.14 so i think that chroot wouild be needed for this.

N4810:/raid/NAS_WebGrab/dotnet_5.0# ./dotnet ../bin/WebGrab+Plus.exe /raid/NAS_WebGrab
./dotnet: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by ./dotnet)
Reply
#3
this can be closed.
i got it working via chroot by mounting my webgrab folder(via chroot module),then in chroot installing dotnet-sdk-5.0
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)